To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

fig.jpg

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive  (), where the two addresses are the addresses of the first nodes of the two words, and  is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by .

Then  lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

#include<iostream>
using namespace std;

struct Node {
	char Data;
	int Next;
	bool flag=false;//在第一个字符串中有无出现过
}nodes[100010];

int main() {
	int A;//字符串1起始
	int B;//字符串2起始
	int N;//字符数量
	cin >> A;
	cin >> B;
	cin >> N;
	int address;
	for (int i = 1; i <= N; i++) { cin >> address;
		cin >> nodes[address].Data;
		cin >> nodes[address].Next;
	}
	int index = A;
	while (index != -1) {
		nodes[index].flag = true;
		index = nodes[index].Next;
	}
	index = B;
	while (index != -1) {
		if (nodes[index].flag == true) {//找到A已经放问过的第一个字符
			break;
		}
		index= nodes[index].Next;
	}
	if (index != -1) {//未到结尾就已经退出,表面有公共节点
		printf("%05d", index);
	}
	else
	{
		cout << -1;
	}
}