wbfg.JPG

The above picture is from Sina Weibo, showing May 23rd, 2019 as a very cool “Prime Day”. That is, not only that the corresponding number of the date 20190523 is a prime, but all its sub-strings ended at the last digit 3 are prime numbers.

Now your job is to tell if a given date is a Prime Day.

Input Specification:

Each input file contains one test case. For each case, a date between January 1st, 0001 and December 31st, 9999 is given, in the format yyyymmdd.

Output Specification:

For each given date, output in the decreasing order of the length of the substrings, each occupies a line. In each line, print the string first, followed by a space, then Yes if it is a prime number, or No if not. If this date is a Prime Day, print in the last line All Prime!.

Sample Input 1:

20190523

Sample Output 1:

20190523 Yes
0190523 Yes
190523 Yes
90523 Yes
0523 Yes
523 Yes
23 Yes
3 Yes
All Prime!

Sample Input 2:

20191231

Sample Output 2:

20191231 Yes
0191231 Yes
191231 Yes
91231 No
1231 Yes
231 No
31 Yes
1 No

#include<iostream>
#include<algorithm>
#include<math.h>
#include<string>
using namespace std;

bool is_prime(int n) {
	if (n == 1||n == 0) return false;
	for (int i = 2; i < sqrt(n); i++) {
		if (n % i == 0) return false;
	}
	return true;
}

int stringtoint(string str) {
	int ans=0;
	for (int i = 0; i < 8; i++) {
		ans += (str[i]-'0') * (int)pow(10, 8 - i - 1);
	}
	return ans;
}
int main() {
	string num;
	cin >> num;
	int num_i = stringtoint(num);
	//cout << num_i;
	bool is_all_prime = true;
	for (int i = 0; i < 8; i++) {
		int temp;
		bool isprime;
		temp = num_i % (int)(pow(10, 8 - i));
		isprime = is_prime(temp);
		for (int j = i; j < 8; j++) {
			cout << num[j];
		}
		cout << ' ';
		if (isprime == 1)cout << "Yes";
		else { is_all_prime = false; cout << "No"; }
		if (i < 7)cout << endl;
	}
	if (is_all_prime == 1)cout <