Problem Description

给定一个日期,输出这个日期是该年的第几天。

Input

输入数据有多组,每组占一行,数据格式为YYYY/MM/DD组成,具体参见sample input ,另外,可以向你确保所有的输入数据是合法的。

Output

对于每组输入数据,输出一行,表示该日期是该年的第几天。

Sample Input

1985/1/20

2006/3/12

Sample Output

20

71

#include<iostream>
using namespace std;

int main() {
	int count[12] = { 31,0,31,30,31,30,31,31,30,31,30,31 };
	int year;
	int mouth;
	int day;
	int days = 0;//第几天
	while (cin >> year && cin.get() && cin >> mouth && cin.get() && cin >> day) {
		if ((year % 4 == 0 && year % 100 != 0) || year % 400 == 0) {//闰年判断
			count[1] = 29;
		}
		else {
			count[1] = 28;
		}
		for (int i = 1; i < mouth; i++) {
			//cout << count[i] << endl;
			days = days + count[i-1];
		}
		days = days + day;
		cout << days << endl;
		days = 0;
	}
}