1001 A+B Format

Calculate a+b and output the sum in standard format — that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b

where −10^6≤a,b≤10^6. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

#include<iostream>
#include<algorithm>
#include<iomanip>
#include <ctype.h>
#include<string.h>
#include<string>
#include<cstring>
#include<stdio.h>
#include<stack>
using namespace std;

int main() {
    stack<int> num;
    int a, b;
    cin >> a >> b;
    int sum;
    sum = a + b;
    int temp=abs(sum);
    if (sum < 0)cout << '-';
    if (temp == 0)cout << 0;
    while (temp > 0) {
        num.push(temp % 10);
        temp = temp / 10;
    }
    int count = num.size();
    while (!num.empty()) {
        if (num.size()%3==0&&num.size()!=count)cout << ',';
        cout <<num.top();
        num.pop();
    }
}