1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K NaNNaN2 … NK aNK

where K is the number of nonzero terms in thepolynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2 2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

#include<iostream>
#include<algorithm>
#include<iomanip>
#include <ctype.h>
#include<string.h>
#include<string>
#include<cstring>
#include<stdio.h>
#include<stack>
using namespace std;


int main() {
    float a[1001] = { 0 };// 下标表示指数,值表示系数
    int num;
    cin >> num;
    int index = 0;
    float b = 0;
    for (int i = 0; i < num; i++) {
        cin >> index;
        cin >> a[index];
    }


    cin >> num;
    for (int i = 0; i < num; i++) {
        cin >> index;
        cin >> b;
        a[index] = a[index] + b;
    }

    int count = 0;
    for (int i = 0; i < 1001; i++) {
        if (a[i] != 0)count++;
    }
    cout << count;
    for (int i = 1000; i >= 0; i--) {
        if (a[i] != 0) {
        cout << " " << i << " " << setiosflags(ios::fixed);
        cout.precision(1);
        cout<< a[i];
        }
    }
}