1009 Product of Polynomials

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 aN1 N2 aN2 … NK aNK

where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤NK<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2 2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

#include<iostream>
#include<algorithm>
#include<iomanip>
#include <ctype.h>
#include<string.h>
#include<string>
#include<cstring>
#include<stdio.h>
using namespace std;

int main() {
    int K_A;int K_B;
    int index=0;
    cin >> K_A;
    float coe=0;float A[1001] = {0};float ans[2010] = {0};
    for (int i = 0; i < K_A; i++) {
        cin >> index>>coe;
        A[index]=coe;
    }
    cin >> K_B;
    for (int i = 0; i < K_B; i++) {
        cin >> index>>coe;
        for (int j = 0; j < 1001; j++) {
            ans[index + j] += coe * A[j];
        }
    }
    int count=0;
    for (int i = 2000; i >=0; i--) {
        if (ans[i] != 0.0)count++;
    }
    cout << count;
    for (int i = 2000; i >= 0; i--) {
        if (ans[i] != 0.0) {
            cout << ' ' << i << ' ';
            cout << setiosflags(ios::fixed);
            cout.precision(1);
            cout << ans[i];
        }
    }
}