1013 Battle Over Cities

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3

1 2

1 3

1 2 3

Sample Output:

1

0

0

#include<iostream>
#include<algorithm>
#include<iomanip>
#include <ctype.h>
#include<string.h>
#include<string>
#include<cstring>
#include<stdio.h>
#include<math.h>
using namespace std;


//因为当a个互相分立的连通分量需要变为连通图的时候,只需要添加a-1个路线,就能让他们相连。
//所以这道题就是求去除了某个结点之后其他的图所拥有的连通分量数
//方法,深搜,求联通分量数
int N;//城市总数<1000
int M;//残存公路条数
int K;//要检查的城市数量
//输出,关于每个城市需要修复的高速数量如果城市失陷

int G[1010][1010] = {0};//邻接矩阵
bool visit[1010] = { false };//判断是否被访问

int concern_city[1010];//需要检查的城市数量

void dfs(int node) {
    visit[node] = true;
    for (int i = 1; i <= N; i++) {
        if (visit[i] == false && G[node][i] == 1) {
            dfs(i);
        }
    }
}

int main() {
    cin >> N >> M >> K;
    for (int i = 0; i < M; i++) {
        int x = 0;
        int y = 0;
        cin >> x >> y;
        G[x][y] = 1;
        G[y][x] = 1;
    }
    for (int i = 0; i < K; i++) {
        cin >> concern_city[i];
    }
    for (int i = 0; i < K; i++) {
        fill(visit, visit + N + 1, false);
        int count = 0;//计算联通分量数
        visit[concern_city[i]] = true;//去掉的点直接赋true,即表示不会访问
        for (int j = 1; j <= N; j++) {
            if (visit[j] == false) {
                dfs(j);
                count++;
            }
        }
        cout << count - 1 << endl;
    }
}