1069 The Black Hole of Numbers

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 — the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 – 6677 = 1089
9810 – 0189 = 9621
9621 – 1269 = 8352
8532 – 2358 = 6174
7641 – 1467 = 6174
… …

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer  in the range .

Output Specification:

If all the 4 digits of  are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 – 6677 = 1089
9810 – 0189 = 9621
9621 – 1269 = 8352
8532 – 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 – 2222 = 0000

#include <iostream>
#include <string>
#include <algorithm>
#include<math.h>
#include<queue>
#include<vector>
using namespace std;

int to_num(int a, int b, int c, int d) {
    return a * 1000 + b * 100 + c * 10 + d;
}
int get_increase(int a[]) {
    return to_num(a[0], a[1], a[2], a[3]);
}
int get_decrease(int a[]) {
    return to_num(a[3], a[2], a[1], a[0]);
}

int main() {
    int num;
    cin >> num;
    int num_seq[4];
    num_seq[0] = num / 1000;
    num_seq[1] = num / 100 % 10;
    num_seq[2] = num / 10 % 10;
    num_seq[3] = num % 10;
    if (num_seq[0] == num_seq[1] && num_seq[1] == num_seq[2] &&  num_seq[2] == num_seq[3]) {
        cout << num << " - " << num << " = " << "0000";
    }
    else {
        int ans=0;
        do {
            sort(num_seq, num_seq + 4);
            int a = get_decrease(num_seq);
            int b = get_increase(num_seq);
            ans = a - b;
            printf("%04d - %04d = %04d", a, b, ans);
            cout << endl;
            num_seq[0] = ans / 1000;
            num_seq[1] = ans / 100 % 10;
            num_seq[2] = ans / 10 % 10;
            num_seq[3] = ans % 10;
        } while (ans != 6174);
    }
}